We're updating the issue view to help you get more done. 

Upgrade fails from 18.1.3 to 19.1.1 with postgresql error on Open SUSE

Description

After upgrade from 18.1.3 to 19.1.1, PBS fails to start with below error:

linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 #
linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 # /etc/init.d/pbs restart
Restarting PBS
Stopping PBS
Shutting server down with qterm.
PBS server - was pid: 20481
PBS mom - was pid: 20194
PBS sched - was pid: 20206
PBS comm - was pid: 20172
Waiting for shutdown to complete
Starting PBS
PBS Home directory /var/spool/pbs needs updating.
Running /opt/pbs/libexec/pbs_habitat to update it.
***
It appears that PostgreSQL has been upgraded independently of PBS Pro.
The PBS Pro database must be manually upgraded. Please refer to the
instructions in the release notes for version 19.1.1.beta1 located here:
https://github.com/PBSPro/pbspro/releases
linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 #
linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 #

PostgreSQL versions were same before and after Upgrade:
linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 # psql -V
psql (PostgreSQL) 10.6
linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 #
linux-3jv8:/home/shilpk/Desktop/pbspro_19.1.1.beta1.opensuseleap.15 #

Steps to Reproduce:
1. Install 18.1.3 PBS on OpenSUSE Leap 15.0 using normal rpm installation.
2. Submit few normal sleep Jobs.
3. Perform upgrade using below command:
“rpm -U pbspro-server-19.1.1.beta1-0.x86_64.rpm”
4. Restart the PBS after upgrade:

Before and after upgrade PG_VERSION shows value as 10.

Acceptance Criteria

None

Status

Assignee

Unassigned

Reporter

Shilpa Kodli

Severity

None

OS

None

Start Date

None

Pull Request URL

None

Story Points

1

Affects versions

19.1.1

Priority

Low